Could not get lock /var/lib/dpkg/lock解决方案

在Ubuntu中,有时候运用sudo  apt-get install 安装软件时,会出现一下的情况

主要是因为apt还在运行,此时的解决方案是

继续阅读

Ubuntu 18.04 + Nginx 的环境下启用 TLS 1.3

TLS 1.3 是最新的安全传输协议,目前已经被主流系统和浏览器支持了,主流网站(如 Google)也早已开启了 TLS 1.3 的支持。本文介绍如何在 Ubuntu 18.04 + Nginx 下开启 TLS 1.3 的支持。

升级 Ubuntu 和 Nginx

首先升级至 Ubuntu 18.04.3,这是当前的最新版本。如果想要在 Nginx 下启用 TLS 1.3 的全部特性,包括 0-RTT,建议使用 Nginx 的最新 Stable PPA。

继续阅读

Docker容器下CouchDB 配置

1. 查看CouchDB容器ID

 2. 进入CouchDB容器

  继续阅读

Docker 安装

  1. Docker安装

2. Docker Compose安装

3. 无法运行docker-compose,由于当前用户不在docker用户组,按照以下添加即可:

继续阅读

idea之将Maven的jar包安装到本地仓库

1.问题概要

很多时候,我们需要应用第三方的jar包,但是这个jar包,在maven远程仓库里面没有,

比如我们要使用京东的sdk,但这个sdk在maven的远程仓库中没有,于是我们需要将这个jar包安装到我们本地仓库.

2.在idea中的安装方法

这里以安装京东的sdk为例,进行演示

京东的sdk包放在如下盘符里面:

继续阅读

Ubuntu16.04怎样安装Python3.7

Ubuntu16.04默认安装了Python2.7和3.5

请注意,系统自带的python千万不能卸载

  1. 检查当前版本号,输入命令python
  2. 按Ctrl+D退出python命令行
  3. 输入命令
  4. 按Enter确认
  5. 输入命令
  6. 调整Python3的优先级,使得3.7优先级较高
  7. 更改默认值,python默认为Python2,现在修改为Python3
  8. 此时再输入命令python,可以看到此时已经是Python3.7了

系统创建定时执行任务bat批处理删除指定N天前文件夹的文件

首先我们要创建一个.bat的文件,下面是创建删除几天前D盘backup目录下的文件

将以上其中一行复制,新建.txt文本文件,粘贴并保存为.bat格式

继续阅读

SpringBoot设置cors跨域请求的两种方式

1、第一种:

继续阅读